martedì 17 luglio 2007

INSTALLAZIONE CODEC MULTIMEDIALI E TOTEM 2.19.2

Per installare i codec multimediali necessari a visualizzare e riprodurre file multimediali con il programma totem, dobbiamo installare i plugin gstreamer e i w32 codecs, apriamo il terminale e digitiamo:

sudo apt-get install gstreamer0.10-plugins-ugly
sudo apt-get install gstreamer0.10-plugins-ugly-multiverse
sudo apt-get install gstreamer0.10-plugins-bad
sudo apt-get install gstreamer0.10-plugins-bad-multiverse
sudo apt-get install gstreamer0.10-ffmpeg

per i w32 codecs necessari a visualizzare i formati windows scriviamo sempre da terminale.

wget -c http://www.debian-multimedia.org/pool/main/w/w32codecs/w32codecs_20061022-0.0_i386.deb

finito lo scaricamento trovate il pacchetto w32codecs dentro la vostra cartella home, installatelo con gdebi o da terminale digitando:
sudo dpkg -i w32codecs*

Adesso che ubuntu risulta aggiornato con i codecs multimediali installiamo l'ultima versione di totem sempre da terminale scriviamo:

wget http://ftp.acc.umu.se/pub/GNOME/sources/totem/2.19/totem-2.19.2.tar.bz2

spostiamo il pacchetto dentro opt:

cd
sudo mv totem-2.19.2.tar.bz2 /opt

scompattiamolo.

cd /opt
sudo tar jxvf totem-2.19.2.tar.bz2

spostiamoci dentro la cartella totem-2.19.2 per compilare il programma.

cd totem-2.19.2
da dentro la cartella diamo i comandi per compilare.

sudo ./configure
sudo make
sudo make install

finita la compilazione troverete il programma, aggiornato alla versione 2.19.2, la compilazione non ha richiesto dipendenze da soddisfare sul mio sistema, credo che anche sul vostro non ne richieda in tutti i casi osservate l'output del comando configure.




8 commenti:

simlav ha detto...

ciau, bella guida e bel sito.
Senti a me non vuole saperne di configurare il pacchetto e mi chiede queste dipendenze:

configure: error: you need the GStreamer or the xine-lib development packages installed

ma quei pacchetti li ho già istallati, credo...

qualche idea??

grazie infinite!

santo vasta ha detto...

prova ad installare da sinaptyc totem-xine
e dopo installa l'ultima versione di totem compilando i pacchetti come trovi nella mia guida.
ciao fammi sapere.

Anonimo ha detto...

mamma mia che casino molto ,più semplice e funzionale Microsoft. Se uno non ha la connessione internet cosa aggiorna? ha un perfetto SO che non legge nulla.

Anonimo ha detto...

Perche', con il tuo windows come li vedi i divx, gli xvid, gli mp4, i file real e i file mkv senza usare una connessione internet?

Sia per Linux che per Windows ci sono pacchetti pronti da installare con tutti i codec e sia per un SO che per l'altro ci sono fix e conflitti a cui talvolta porre rimedio. O tu hai una versione speciale di Windows che non necessita di codec aggiuntivi?

Giasone ha detto...

Le considerazioni sulla difficolta lasciano il tempo che trovano, se per te è un casino continua ad utiliizzare win**owsss che è meglio cosi eviti qualsiasi casino (non ne sono convinto) e ti fai spiare da zio bill. Contento tu contenti tutti.

Anonimo ha detto...

Salve a tutti anch'io sono nuovo di Ubuntu....sul computer dov'è installato non c'è una connessione internet...come faccio a installare i codec per il totem (o qualsiasi altra cosa mi permetta di ascoltare mp3 e di visualizzare altri formati) senza internet ?
Grazie a chiunque mi aiuti in questa impresa ^^

Anonimo ha detto...

Grazie per la risposta.... -.-

Anonimo ha detto...

ciao...praticamente a me non fa spostareil pacchetto dentro opt...

root@teobeo-desktop:~# cd
root@teobeo-desktop:~# sudo mv totem-2.19.2.tar.bz2 /opt
mv: impossibile fare stat di `totem-2.19.2.tar.bz2': Nessun file o directory
root@teobeo-desktop:~#


Helppppp!!!! :) complimenti per il sito ;)