martedì 11 dicembre 2007

webcam z-star ZC0301 riconoscimento su debian lenny

Per tutti quelli che possiedono la webcam z-star chip zc0301 per farla riconoscere su debian testing dovrete seguire questa semplice procedura, per prima cosa aprite un terminale è digitate:

dmesg

verificate se la webcam viene riconosciuta in caso contrario installate il pacchetto gspca che non fa altro che installare dei driver generici utili al riconoscimento della webcam, sempre da terminale scrivete.


sudo apt-get install gspca-modules-2.6.22-3-486

controllate la versione del kernel installata sul vostro sistema potrebbe differire dalla mia per visualizzare la versione del kernel scrivete da terminale uname -a

un altro pacchetto utile al corretto funzionamento delle webcam è il programma camorama sempre da terminale scrivete.

sudo apt-get install camorama


finita l'installazione di camorama riavviamo il computer lasciate la webcam attaccata nella presa usb, verifichiamo l'avvenuto riconoscimento della web scrivendo :

sudo modprobe gspca

lanciamo il programma camorama per attivare la webcam scrivete:


camorama


su ubuntu gutsy non ci dovrebbero essere problemi la web viene riconosciuta in automatico se riscontrate dei problemi seguite la procedura per debian stando attenti alla versione di gspca che installate varia dal kernel effetivamente installato sulla propria macchina per verificare il kernel scrivete uname -a.

3 commenti:

Serpe ha detto...

Non riesco a trovare il pacchetto gspca: Questo è quello che ho fatto su Ubuntu 7.10

gabriele@ATHLON:~$ uname -a
Linux ATHLON 2.6.22-14-generic

gabriele@ATHLON:~$ sudo apt-get install gspca-modules-2.6.22-14-generic
Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso
Reading state information... Fatto
E: Impossibile trovare gspca-modules-2.6.22-14-486-generic

Grazie e complimenti per il blog

santo vasta ha detto...

cerca il pacchetto con sinaptyc vedi se lo trovi cerca gspca
vedi che trovi

Serpe ha detto...

Synaptic mi trova solo il pacchetto "gspca-source", procedo con quello ?