domenica 4 maggio 2008

configurazione ottimale xorg.conf

Dopo aver effettuato l'installazione dei driver video nvidia sia dai repository ufficiali che manualmente utilizzando i driver proprietari ,al riavvio successivo si assiste ad un spiacevole inconveniente praticamente non si riesce a selezionare una risoluzione diversa da quella impostata automaticamente.

Per selezionare una risoluzione specifica bisogna configurare il file xorg.conf manualmente, io nel mio caso ho impostato una risoluzione di 1280x1024.

Procediamo per ordine apriamo il file xorg.conf cerchiamo la sezione Section "Screen"
aggiungiamo la seguente stringa
"1280x1024" "1024x768" "800x600" "720x400" "640x480" dopo modes in pratica indichiamo al server di utilizzare come risoluzione predefinita1280x1024, salviamo la configurazione, al prossimo riavvio otterete la risoluzione prestabilita.



sudo gedit /etc/X11/xorg.conf

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Generic Keyboard" "CoreKeyboard"
InputDevice "Configured Mouse"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "it"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
EndSection


Vi ricordo che per installare i driver nvidia o ati potete servirvi del programma envy che in questa nuova versione di ubuntu viene fornita di default nei repository, installate il pacchetto scrivendo da terminale:


sudo apt-get install envyng-gtk; sudo apt-get install -f

4 commenti:

Anonimo ha detto...

Io provato a fare quella modi in kubunto ma non mi riesce di accedere prileggi amministratore

scrivo:

cd /etx/X11

sudo kate xorg.conf

e mi dice programma non trovato

nota che se non metto sudo il file si appre ma non lo posso salvare

santo vasta ha detto...

devi dare il percorso esatto del file xorg.conf.

dai questo.

sudo kate /etc/X11/xorg.conf

ora dovrebbe funzionare.

ciao

Anonimo ha detto...

Ti ringrazio per la risposta, non ho più provato ma problema non è non trova il file è che kade non parte con comando sudo, ora poi faccio qualche indagine e ti dico il problema secondo me deve essere stickbite (come si chiama) della eseguibile di kate. Come ti ho detto se non uso comando sudo davanti il file si apre regolarmente ma poi non posso poi salvarlo. Mi è venuto in mente di provare a editarlo con vim.

A dire il vero non un problema di configurazione di X e un problema di editore nel caso di Kade.
Ciao

Umberto ha detto...

forse ti mancava il kate !